[注意]ロリポをPHP5にするとa-blog動きません。

ロリポップのサービスでa-blogを利用されていた方から動かなくなったとサポートメールを頂き、調べてみるとどうやら以下のような事が書かれています。

PHP4の今後のご提供につきまして
PHP4は既に開発・サポートが終了しておりますので、2009年春頃を予定として提供を終了させていただきます。 (詳細な予定については別途お知らせいたします)
ただし、今後セキュリティ上の深刻な問題等が発生した場合、やむなく提供を終了する場合もございます。早めにPHP5への切り替えをよろしくお願い致します。

とりあえずは、現状のままで運用していれば動作します。しばらくは、PHP4のままでご利用下さい。


今後の利用で望みがあるところとしては、同社のサービスである「ヘテムル」ではioncubeを標準でインストールして頂いてますし、ロリポのサービスでもphp.iniを特定の項目のみブラウザから編集できるようになっています。ココにioncubeローダーを使うというオプションを追加して頂く事をお願いしてみようと思っています。



また「チカッパ」のリリース情報にも


PHP5
2009年1月より随時対応予定です!もうしばらくお待ちください。

という事が書かれています。


UPDATE:


ロリポップ事業部 サーバー管理チーム より
サーバに ioncubeローダー を標準インストールにする方向で動いている事をご連絡頂きました。ありがとうございます!


コメント

  • Re: [注意]ロリポをPHP5にするとa-blog動きません。

    チカッパ・ロリポユーザーでa-blogを運用してます。

    サーバー側が対応しないということですが、
    a-blogのPHP5対応の予定はあるんですか?

    返信

    投稿者名 山本 一道 Web

  • Re: [注意]ロリポをPHP5にするとa-blog動きません。

    現在、php5については対応していますし、サーバ側でioncubeローダーをインストール頂き、対応できる方向です。

    ご安心下さい。大丈夫です。このエントリー消した方がいいですかね。

    返信

    投稿者名 山本 一道 Web

  • Re: [注意]ロリポをPHP5にするとa-blog動きません。

    なるほど。ということは、【PHP5への切り替えマニュアル】のリンク先にあるように、ロリポの管理画面で 『 PHP5に切り替え 』 をクリックするか、a-blogの拡張子を「 .php5 」にすれば動くのですね?

    PHP5については、ioncubeローダーの問題なんですかね??

    消す必要はないと思いますが、対応状況がちょっとわかりずらいエントリーですね。

    返信

    投稿者名 山本 一道 Web

  • Re: [注意]ロリポをPHP5にするとa-blog動きません。

    現状では、PHP5については、ioncubeローダーの問題で動作しなくなります。

    サーバ側で標準でローダーを入れて頂けるようになった時点で動作するようになります。

    返信

    投稿者名 山本 一道 Web

  • Re: [注意]ロリポをPHP5にするとa-blog動きません。

    今頃のコメントなんですが
    ロリポップサイトにこんな事が書いてありました。

    @@@

    PHP4の今後のご提供につきまして
    PHP4は既に開発・サポートが終了しておりますので、2009年春頃を予定として提供を終了させていただきます。 (詳細な予定については別途お知らせいたします)
    ただし、今後セキュリティ上の深刻な問題等が発生した場合、やむなく提供を終了する場合もございます。早めにPHP5への切り替えをよろしくお願い致します。

    @@@

    そして次に書いてあるのが

    @@@

    【ユーザー専用ページ】[php.ini設定]での「zend_extension」利用について

    ロリポップでは2009年1月6日にて[php.ini設定]をご利用の環境でも
    「zend_extension」が利用できるよう修正を行いました。

    【ユーザー専用ページ】内の[WEBツール]の項目にございます
    『php.iniの設定』より「php.iniを設定する」を押して頂くと利用できます。

    なお、ロリポップ!レンタルサーバーでa-blog等ご利用のお客様は
    「zend_extension」の機能が必要となりますので
    設定ボタンを押して更新をよろしくお願い致します。

    @@@

    となっています。
    という事は、現在a-blogを設置しているロリポップサーバーのPHPバージョンを5にしても
    上記のように設定すれば問題なく動くと考えて大丈夫でしょうか?
    (かずみちさんに質問していいものか迷いましたが…)

    返信

    投稿者名 山本 一道 Web

山本一道

山本 一道

有限会社アップルップル

名古屋のホームページ制作会社「有限会社アップルップル」の代表をしています。弊社で開発しているCMS「a-blog cms」や、名古屋の「WCAN」という名古屋のWeb制作者のためのセミナーの主催や、コワーキングスペース「ベースキャンプ名古屋」も始めました。

エントリーリスト

カテゴリーリスト

タグクラウド

実践! コンテンツファーストのWebサイト運用  a-blog cmsではじめるCMSプロトタイピング

2016年6月30日に株式会社ボーンデジタル様より「実践! コンテンツファーストのWebサイト運用 a-blog cmsではじめるCMSプロトタイピング」が発売されました。