ファイルサーバを OS X Server に!
盆休みを利用してファイルサーバの移行作業を行った。どうもオープンディレクトリというヤツがよく分からずにローカルで作ってファイルサーバに出来ればいいか!って思って作業を進めていた。
ある程度、グループやアクセス権を設定して「ほぼ完成!」ってところで、どうせなら OS X Server らしい事をやりたい気分になって、オープンディレクトリ を有効にして、再度やり直し! デスクトップ系のマックからディレクトリアクセスでリモートデスクトップの設定を行い、うまく動くようになった! 結構、失敗も多くうまく動かせるようにするのに失敗も多かった。
失敗した点を数点
- ユーザーのホームディレクトリを外部のディスクに設定していたのに電源を入れてなかった。(ログインできない)
- ユーザーのパスワードを設定せずにテストをしていた。(リモートデスクトップ環境でログインできない)
- ユーザーのディレクトリをネットワークマウントする設定を忘れていた(もちろんマウントできない)
- ディレクトリアクセスを設定後にクライアント側のマックを再起動してない(これが原因なのかうまくログインできないのがあった)
あまり複雑なアクセス権も設定しなかったので「アクセス制御リスト」は利用せず、グループの権限だけでなんとかなった。それにしても、新規ファイルやフォルダのアクセス権が「標準POSIXビヘイビアを使用」ってのはどんな時に使うもんなんだろ? 「上位のアクセス権を継承する」じゃないとファイルのサーバとして運用できないような気がするんだけど...
このリモートデスクトップ環境で仕事をしようと思ったら、ギガビットのハブも買ってこないとダメですね。でも、なんとかなりそうでよかった! (^_^)
今後の作業
- Windows からの接続設定
- プリントサーバの設定
- ポータブルホームディレクトリのテスト
この記事を書いた人
山本 一道
/
有限会社アップルップル
代表
名古屋のWeb制作会社 (有)アップルップル代表。HTMLファーストな国産CMS「a-blog cms」開発・販売・サポート / 名古屋のWeb制作者コミュニティ「WCAN」主催 / コワーキングスペース「ベースキャンプ名古屋」運営。Web制作の現場をより良くするための活動をしています。
@kazumich関連記事
この記事のハッシュタグ #OSXServer から関連する記事を表示しています。