さくらインターネットでa-blogを動かす2つの方法

少し前にさくらインターネットのPHPの設定が5.2.xになり、a-blogを動かす際に利用している ioncubeローダーが動作しなくなってしまいました。そのため、今まで動作していた a-blog が動かなくなってしまった人も多くいるようです。


PHPの設定を変更する際には、さくらインターネット サーバコントロールパネル というページにアクセスして下さい。


PHPを4.4.8にする(暫定対応)


a-blog 1.7をご利用でない場合、PHP 5.xでの動作については保証できません。最新版でない場合には、最新版にアップデートするまでの暫定対応として、PHPを4.4.8で動作させる設定を行って下さい。なお、PHP4.x系についてはサポートが昨年末に終了しており、重要なセキュリティフィックスも行われない事になっています。その事をご理解の上、ご利用下さい。



アプリケーションの設定のPHPバージョン選択を選択し、PHP 4.4.8 に設定を変更します。a-blogの設置先にアクセスすると動作していると思います。ご確認下さい。


php.ini の設定を変更する (推奨対応)


こちらはPHP5でioncubeを利用できるようにする方法になります。以下の例は appleple.sakura.ne.jp の直下にioncubeのフォルダをアップロードした際の例になります。

アプリケーションの設定のPHP設定の編集をクリックし以下のように設定します。例では、appleple.sakura.ne.jp の場合になりますので、ご自分のIDやインストールされた場所にあわせて設定する必要があります。


zend_extension = /home/appleple/www/ioncube/ioncube_loader_fre_5.2.so


ココをお読みで、さくらインターネットを利用されている方は、この機会によろしければ一度インストールしてお試し下さい。ファイルのダウンロードは以下のリンクになります。



投稿者

RSS 2.0 Login